Flux RSS - La vie du site - Nouveautés et mises à jour
Assiste.com - Sécurité informatique - Vie privée sur le Web - Neutralité d'Internet Assiste.com - Sécurité informatique - Vie privée sur le Web - Neutralité d'Internet

Nombre d'occurrences d'un caractère dans une cellule

Excel - Calculer le nombre d'occurrences d'un caractère dans une cellule. Combien de fois un caractère particulier apparaît-il ?

22.10.2022 : Pierre Pinard.

Dans une cellule d'un tableau de calcul Microsoft Excel, nous avons un contenu textuel et nous souhaitons savoir combien de fois apparaît un caractère particulier.

En A1, saisissons (recopions) le texte :



« Que j'aime à faire connaître le nombre utile aux sages !
Immortel Archimède, artiste ingénieur,
Qui de ton jugement peut priser la valeur ?
Pour moi, ton problème eut de pareils avantages. »

En B1, saisissons (recopions) la formule suivante pour chercher combien de fois apparaît la lettre « a » :
=SOMMEPROD((NBCAR(A1)-NBCAR(SUBSTITUE(A1;"a";""))))

B1 affiche le résultat.


Excel - Calcul du nombre d'occurrences d'un caractère
Excel - Calcul du nombre d'occurrences d'un caractère


Ceci permet de rechercher le nombre d'occurrences d'un unique caractère, pas d'un mot ou d'une chaine de caractères.

MotQuej'aimeàfaireconnaîtrelenombreutileauxsages
Caractères31415926535

Avez-vous compris ?

Il s'agit du premier vers d'un poème assez long et rébarbatif (peu poétique) dont chaque mot a un nombre de caractères correspondant exactement au chiffre qui doit être à cette place. Il est ainsi plus facile de se souvenir de ce poème (enfin... son début) plutôt que de tenter (et jamais y arriver) de se souvenir de plus des 6 ou 7 premiers chiffres du nombre Pi (la constante d’Archimède). On en a besoin partout, en physique, ingénierie, mathématiques, etc.

Les 16 premiers chiffres de l'écriture décimale de Pi sont 3,141 592 653 589 793 (lorsque j'avais 4 ans, mon père testait sans cesse mon par cœur de ce premier vers de ce « poème »).

En 2013, on connaissait déjà plus de douze mille milliards de décimales de Pi.

# # # # # # # # # # # # # # # # # # # # # # # # # # # #