Alertes de sécurité en coursDiscussionDiscussion
Faire un lienLien
Assiste.com - Sécurité informatique - Décontamination - Antivirus - Protection - Protection de la Vie Privée Assiste.com - Sécurité informatique préventive - Décontamination - Antivirus - Protection - Protection de la Vie Privée


Excel - Calcul clé NIR (numéro de Sécurité sociale)

Dernière mise à jour : version du 07.01.2017 - 2017-01-07T00:00
2017-01-08T00:00 - Assiste - Pierre Pinard - Mise à jour

Comment calculer le chiffre clé (la clé de contrôle) d'un numéro de sécurité sociale

Excel - Calcul clé NIR (numéro de Sécurité sociale)

Excel - Calcul clé NIR (numéro de Sécurité sociale)    Excel - Calcul clé NIR (numéro de Sécurité sociale)    Excel - Calcul clé NIR (numéro de Sécurité sociale)    Excel - Calcul clé NIR (numéro de Sécurité sociale)

Dossier (montrer / masquer)
Table des matières (montrer / masquer)

Excel - Calcul clé NIR (numéro de Sécurité sociale) - Excel - Calcul clé NIR (numéro de Sécurité sociale) Excel - Calcul clé NIR (numéro de Sécurité sociale)Ecrire à Assiste.com - Excel - Calcul clé NIR (numéro de Sécurité sociale) - Excel - Calcul clé NIR (numéro de Sécurité sociale) Excel - Calcul clé NIR (numéro de Sécurité sociale)

On suppose que le numéro de Sécurité Sociale se trouve dans la cellule A1 de la feuille de calcul.

Le calcul ne pouvant se faire que sur des données numériques, on remplace conventionnellement, dans la formule, la présence des départements corses (2A et 2B) par 18 et 19.

D'autre part; le résultat doit être sur 2 chiffres, donc on force un format à 2 chiffres avec, si nécessaire, un zéro à gauche.

Le formule complète est donc :
=TEXTE(97-MOD((MOD(CNUM(STXT((SUBSTITUE(SUBSTITUE(A1;"2B";"19";1);"2A";"18";1));1;7));97)*27)+(MOD(CNUM(STXT((SUBSTITUE(SUBSTITUE(A1;"2B";"19";1);"2A";"18";1));8;6));97));97);"00")

Excel - Calcul clé NIR (numéro de Sécurité sociale) - Excel - Calcul clé NIR (numéro de Sécurité sociale)

Excel - Calcul clé NIR (numéro de Sécurité sociale) - FAQFAQExcel - Calcul clé NIR (numéro de Sécurité sociale) - FAQExcel - Calcul clé NIR (numéro de Sécurité sociale)

Excel - Calcul clé NIR (numéro de Sécurité sociale) - ConseilsConseils essentielsConseilsExcel - Calcul clé NIR (numéro de Sécurité sociale)